Mic on Mac
  • I bought Audulus 3 (for MacOS) last night and working through the examples. However, I cannot get the "Mic"-node to work. Is this feature yet to be implemented or am I missing something? Thanks.
  • The mic node should be working. The name "Mic" is a bit misleading. The Mic node actually represents the system audio input. If your Mac is configured so that something other than the mic is currently the system audio input, that audio will be what's output by the node. You can go to System Preferences/Audio or open Audio/MIDI Setup in Applications/Utilities to configure your audio input.
  • Hey alrioth! Welcome to Audulus, or at least Audulus for Mac!

    Can you describe how you want the Mic node to work? Do you have a Microphone you want to use? If so, how is it plugged into the computer?
  • Hello biminiroad,

    I was hoping that the Mic node was reading sound directly from the sound input (initially just to play around with effects, etc).

    I have an microphone plugged in via "NI Komplete Audio 6" audio-interphase attached via USB. In an A3 empty "New patch", I have created one "Mic" node connected to two "Value" nodes. They do not read anything (other than zero). In other applications the sound input works fine. I have also tried to use the internal mic of the computer to no avail.
  • So the Mic node reads inputs 1 (bottom) and 2 (top). I know you might expect input 1 to be on top and input 2 on bottom, but Taylor started Audulus a while back with this bottom to top labeling convention that hopefully will change in Audulus 4 since it seems to confuse people.

    So can you tell which input the Mic is attached to, and if so, can you tell if it's attached to input 1 or 2 (if you have it hooked up to an input 3-16, you can use the ADC node and set it to the proper channel).

    If you have the mic set up now, can you then put an effect between the mic node and the speaker node and confirm you're getting sound out? Keep in mind you may need a level node in between as a volume control.
  • Just to add to @biminiroad's advice. Unlike most DAWs, Audulus has no mechanism to select a specific audio device. It uses whatever is set as the system audio device. If your interface is not selected as the system audio input, you won't get any sound.
  • I have the physical microphone attached to input 1 on my "Komplete Audio 6", this is the system audio device. It works in all other applications (Logic Pro X, Skype, etc.).

    In A3 i have mic->delay->level->speaker setup (see attachment).
    1887 x 1119 - 154K
  • It certainly looks like you have things set up properly. I use a Focusrite Scarlett 6i6 which is a very similar interface to the Komplete Audio. I have used it in the past with no issues, but I decided to replicate your setup. I have a mic attached to channel one and have verified that the mic works in other applications. I created a patch with the same configuration as yours and I don't get any sound either. I'm on macOS 10.13.2 I don't use an external input often with Audulus on the Mac, mostly on the iPad, so it's been some time since I've had this setup, but I'm pretty sure it worked before. I also couldn't get the internal mic to work. I verified that the mic node works in the AU plugin, but that's older Audulus code. I also plugged my interface into the iPad and the mic node works as expected on the iPad.
  • I still haven't heard anything back on the bug report I filed. I tried it on my other Mac and have the same problem. I'm thinking it's something in the latest version of macOS.
  • @stschoen - sorry I've been out of touch, I'll be check this out tomorrow after we get done with this new iOS release!
  • Not a huge deal, but my current vocoder patch won't run on the iPad and I'm anxious to try it out. I'm sure @alrioth would appreciate it as well.
  • "or at least Audulus for Mac" .....is the macOS version considered secondary?
  • @jimmy I think the macOS is considered the best one for building complex patches actually. I know that @biminiroad uses it for most of the tutorials so I am pretty sure that it's just he never uses the mic input on the mac version because he uses the iPad when playing.
  • thats good to hear. was trying to get into audulus after long pause since i got some new hardware and this is the first thing i tried :D :/ :( ...so yeah one vote from here too to get audio input function.
  • Issue resolved. With the new update for OSX it works perfect. Already having fun! Thank you so much!
  • @jimmy Just saw your comments - no, Audulus for Mac is hardly secondary! It's the one I use the most personally. Not exactly sure why I said it that way, but yeah.

    @alrioth - thanks for pointing out it's fixed! Yes, this was an upgrade in 3.5 :)
  • I’m glad to have audio in working again. I believe it was something in macOS High Sierra that caused the issue