Crashing in AU plugin and other weirdness
  • I'm getting crashes and weird behaviour when I'm using the AU plugin.

    I started a patch in the standalone version and saved it. Then I loaded it in Ableton Live in the AU plugin and made a few changes and then saved it from there. I did this a few times and then suddenly the file would no longer open in the stand alone version but still open in the AU version in Ableton. So in the plugin version I changed the file slightly and then exported it as a different file to see if that would open but this didn't work.

    I then tried to open the original file in the AU plugin but this now crashed Ableton completely even though it opened previously and I hadn't made any changes to the file. Does Audulus make changes to the file you are working on even though you haven't saved it?

    So now I am left with two files neither of which will open in the standalone. One of these will open in the AU version and the other crashes the host. I have tested it in Ableton Live and Renoise and had the same results with both.

    I have attached the files..
    Test Patch - The original file that I was working on that now crashes the host when loaded
    Test Patch 2 - The copy file I saved that opens in the the AU but not the standalone.

    Neither of these open in the standalone and I can send the crash logs if they are needed.

    On another note is there a way to exit a patch node when using the AU plugin, pressing 'e' doesn't work and this was the main reason I was switching between the plug and standalone! I suggest that double clicking the background takes you up a level instead, I think this would work better for a mouse driven workflow.

    Test Patch.audulus
    Test Patch 2.audulus
  • @afta8, sorry about that! Can you send me the crash reports? (email is best:

    I'll test out those patches and figure out the problem.

    Also I'm going to have a "Exit Sub-Patch" button in the AU at the very least. I like your idea for double-clicking on the background, but I was thinking of making the double-click zoom to fit everything, like the double-tap on the iPad.

    - Taylor
  • Hey,

    Thanks for the speedy response, I'll email the reports.

    The exit sub patch button would work just as well! Although so far I rarely need to zoom out to fit everything in, when I do pinch gestures work well enough for me. But then I have only been using this for one day!!

    Have to say, bugs aside, I am really enjoying playing with this.


  • @afta8, glad you're liking the app :-). I've reproduced the crash and it should be a pretty straightforward fix. In fact this class of errors are recoverable... I just need to build in some UI that informs the user of the problem, rather than just quitting the app.

    - Taylor
  • @Taylor, thanks, I look forward to the fix, crashing the host DAW is a bit severe!

    I came across another unrelated issue in the standalone version so I'll post it here rather than start another thread.

    The poly sound of an Osc node changes if it is put inside a patch node. Have a look at the attached file, if you switch the keyboard to poly mode and play a single note the sound is quite different to when it is in legato mode, it becomes metallic sounding kind of like it has a short delay on it, is there a way to avoid this or do patch nodes not support poly mode?

  • @afta8, ok here are new versions to try: 1.8 Unsabdboxed Beta Audio Unit 1.8 Beta.pkg

    Let me know if they work :-)

    Yes, the Patch node currently doesn't support being run polyphonically. I've been working on a fix for that for a while, and I think I've got it, but its "high risk" in that it makes fundamental changes to how polyphony works internally (it could cause other bugs). So I suspect I'll have that out in the version after next. Sorry about that! I can send you another version to test with my experimental fix if you'd like.

    - Taylor
  • Wow that is quick!! Thanks a lot :) I'll give the new version a try.

    Sure, send me the experimental high risk version :) As long as it doesn't blow my computer up I'll be keen to test it out. I didn't realise the Patch Node was more than just a graphic tweak so I'm happy to help you get poly working in it.

    Will it have this AU fix in it as well or will I be testing out two versions?

    Also out of curiosity is Audulus programmed in lua?

  • @afta8, yeah its only implemented as more than a graphic tweak because patch nodes can be "instanced," which means you can share the same sub-patch in different contexts. If you right lick on the patch node, its the "Instance Patch" option.

    In fact its this instancing feature that is conflicting with polyphony. Now that you point it out, I'm going to revisit implementing the patch node as more of just a graphic tweak (though because of instancing, it can't simply be a graphical grouping of nodes). Earlier I had thought this would complicate things too much, but not doing it that way has lead to other complexity. So thanks!

    Yes, I'll get the experimental version all synced up so it will have the other fixes in it.

    Most of the Audulus UI interaction logic is written in Lua. The DSP and graphics rendering parts are written in C++ for performance reasons.

    - Taylor
  • @Taylor, I hadn't really looked at the 'Instance Patch' option, just had a play and if I understand correctly this creates an 'alias' (to use a sequencing term) of the patch node, if you make a change to any 'instance' then this change happens to all instances. This is different to copying and pasting which would create unlinked patch nodes.

    Seem a nice feature to have although it could get confusing if you have a mixture of copies and instances. Maybe if there was some graphical indication to show when a patch node is an instance, a different background colour perhaps.

    Although I am new to the programme and modular synthesis in general I personally can't see myself using this feature more than copy and paste as I would want to leave the option open to modify instances without affecting the parent and vice versa. Maybe if there was an option when modifying an instance to make the change unique and break the link to other instances.

    On lua, I have been teaching myself it over the last year as Renoise allows users to develop tools in Lua that plug into the programme, I've made a few tools and although I'm not very advanced in my skills I'm interested to see how a lua scripting interface would work in this. Check Renoise out if you haven't already its very good.

    Anyway, I look forward to the update and thanks again for being so responsive!


  • @Taylor, I came across another issue regarding file sizes, I was working on the linked file in Beta 1.8 and after a few copy and pastes the file size went from 330k to 15.1mb. I don't think is normal as the file is not that different from the earlier version, its now a lot slower to open and save. Synth Test.audulus

  • @afta8, ah yes. I've encountered one of those before. In Audulus, if there's a memory leak, it can be pretty bad and bloat the file size. In this case, even when you delete all the nodes and clear the history, the file size is still 15.1mb. That's quite a leak!

    Last time I wrote some code that finds the leaks, so I should be able to get that fixed soon. Thanks for letting me know!

    - Taylor
  • I've been able to recover those patches on my Mac by selecting all and copy pasting to a new empty patch and deleting the old one.
  • @Dcramer, nice work-around!

    @afta8, I've fixed the patch, while also retaining undo history, and plugged the memory leak that was causing the file to grow. The fix will be in the next version :-)

    - Taylor
    PWM Synth Test FIXED.audulus
  • @Dcramer, thanks for the tip, I tried that but it didn't work, its weird because if I delete all nodes in the original and save it, the file size is still huge, so I figured the error is in the encapsulating file and not the nodes, however copying all the nodes into a new file creates a new file that still has the problem!

    @Taylor, thanks for fixing the file, it all works ok so I can continue working on my first synth :)

    With regards to the 1.8 Beta 2, it seems to work fine and now loads the files that I couldn't open before, thanks!

    There is however a problem with AU installer, when run it deletes the previous component files, installs a folder called 'Contents' and doesn't install any new component files. Nothing shows up in any DAWS so I can't test this.

  • @afta8, I always manage to goof up the AU somehow :-\. I'll fix that and post a new one shortly.
  • @afta8, I'm not sure what was going on with the installer package, but I rebuilt it and it seems to work fine. Give it another shot and let me know if it works :-) Audio Unit 1.8 Beta.pkg
  • @Taylor, thanks works great, thanks for the 'Exit Sub Patch' button... Yay, good times!