FIXED: Mac Mini users: Audulus Crashes on Startup on Mac Minis w/o Microphones
  • Hey foks,

    We found a bug where Audulus will crash on a Mac mini because Audulus is expecting every Mac to have an audio input device.

    We're working on a fix and will submit to Apple ASAP!

    Sorry for the inconvenience!
    - Taylor

    *Update: This is now fixed*
  • Any of you crashers on Mac Mini - do you have Soundflower installed? If not, try installing that and let me know if that fixed it. This isn't an official fix (Taylor's working on that) but this might be a work-around for now. Plus, why don't you have Soundflower already? ;)
  • @biminiroad


    The reason some users may not have Soundflower installed and why you may not want to whole heartedly recommend it, without reservations.. is that Soundflower (and other audio routing type apps for that matter) can easily cause issues with certain Audio Interfaces and their drivers resulting in unstable systems that can and often do end up in CoreAudio crashing with alarming regularity...

    On Apple's Logic forums for example, it is one of the first questions we ask... "Do you have Soundflower or Jack installed?" as more often than not, those with unstable systems, have an audio router installed, hence their issue... Removing the router, often stabilizes their system again.

    That's not to say, that such audio routing apps always cause such instability issues... but history shows one should proceed with caution before installing one and make sure you have a full working backup, before doing so, just in case.



    aka The Art Of Sound - Apple Logic Community
  • @n6smith Huh thanks! Never knew that. I think it's absolutely silly that there isn't something like SF that is Apple Native. I guess it might be to prevent screen cap + audio to record movies or something, but whatevs.
  • Thanks to both of you for the Soundflower info. I've seen it in the past but never messed with it. Yeah... I will wait for the next update. I plugged in an Ion Audio USB phono input I have... that actually allowed the app to run but the audio engine still wasn't happy.

  • @biminiroad

    "I think it's absolutely silly that there isn't something like SF that is Apple Native."

    Couldn't agree more.. It's something we have been pushing hard for over at the community.. for a long time now but sadly without response (so far).
  • Oh crazy me. I don't know why I do these things but I had a Logitech USB microphone collecting a lot of dust somewhere behind a pile of CDs. I plugged it in and of course it needed no drivers and OS X saw it immediately as a class device.
    I clicked on Audulus and it started up first go.
    This is the same cheap Logitech desktop mic they have sold for decades now so it's nothing special. If you have an old mic, either USB or 1/8 inch jack for your audio in.....

    Attn: Taylor and/or Bimini
  • @Minermike61, cool! Yeah that's a decent work-around for now. If you have a USB microphone (or audio interface), just plug it in :)

    I've submitted a fix to Apple :)
  • That's curious. My MacMini is normally connected via HDMI to an ASUS monitor. It also connects to a MOTU Ultralite if i've turned it on. When the MOTU isn't on I get no input device if I load into Logic / Ableton Live / Audition. But it appears to not bother Audulus 3 as I've not had any crashes so far.
  • @LutherBlissett, that's interesting. We were able to reproduce the crash on @biminiroad's mini, and verified that the fix worked. Maybe there's some other reason why it works fine on your mini.
  • @LutherBlissett @Minermike61
    This should be fixed now. Is everything good on your ends? :)
  • I just hit Update. Seems to be working now. No problems with startup even though it still shows my "input" as the USB device even though it is no longer plugged in. This probably isn't an issue. The audio engine seems to be working and I now have blinkly lights and audio output. Hooray.

  • @grantbob, excellent! Yeah it just shows the previous setting even if that isn't available. Kind of a bug which I should fix.
  • @grantbob, you should be able to click on the menu and set it to no input. Does that work?
  • There's no "blank" or empty setting to choose from. But if you click on the "ghost entry" of the USB device that is no longer there, it blanks it out and the "ghost entry" is no longer available.
  • exactly, thanks @grantbob -while testing bugfix, i waited on customer service with Universal Audio after uninstalling, unplugging my UAD software and it was STILL there and I was Until I got on the phone with the guy and then clicked on it - it disappeared, and I didn't need him anymore. :O ahha