iCloud on OS X not working correctly with Audulus 3
  • Hello,

    First of all I want to thank you for creating this amazing app, I've wanted to buy Reaktor for a long time but this has so much more bang for buck and also having an iOS version is a huge plus.

    That said, there seems to be a bug with iCloud in the OS X version. See the attached screenshot; the Audulus folder is not appearing and in the sidebar the folder name seems to be blank. I have also bought the iOS version and the iCloud sync between my iPad and iPhone works perfectly, only the OS X version cannot see the files created on my iPhone/iPad. I tried to uninstall/reinstall (using AppDelete) and I have rebooted my Mac, but unfortunately this doesn't help.

    It does seem that the files from my iOS devices are somehow synced to my Mac because there is a ~/Library/Mobile Documents/iCloud~com~audulus~audulus/Documents folder that I found while looking around my system with Terminal (see the other attached screenshot). So it seems that the actual sync is working, it's just that the OS X app is not actually showing the files that are on my Mac.

    Thanks for your help,
    Bas
    OpenFileScreen.png
    796 x 532 - 70K
    MobileDocumentsDir.png
    508 x 252 - 32K
  • By the way, I also tried turning Audulus 3 off and on in the iCloud Drive options in System Preferences.
  • Installed Audulus 3 on my MacBook Air with OS X 10.11.2, same problem.
  • I can confirm something strange going on. I'm still on OSX 10.10.5 and iOS 8.4.1
    Just downloaded the new fourth tutorial, dragged into my iCloud Drive (which is curiously empty) and it doesn't show up on iPad Audulus. It can be selected through OSX Audulus but if you look at the image the actual iCloud directory comes up as a discrete separate hidden drive (top). Not sure what the other one (under Favorites) achieves but turning iCloud off in OSX System Preferences makes it go away.
    Opening downloaded files from wherever and then saving within the OSX app to the hidden directory is the way to make them show up on iPad.
    Screen Shot 2015-12-13 at 1.41.18 pm.png
    204 x 129 - 11K
  • Looks like you have exactly the same problem as I have. I solved it for now by symlinking the hidden Audulus folder in ~/Library/Mobile Documents to my Desktop like this:

    ln -s ~/Library/Mobile\ Documents/iCloud~com~audulus~audulus/Documents ~/Desktop/Audulus-iCloud

    This way you can at least easily access the folder that syncs with the iOS version. Would be nice if the developer could respond to this thread to acknowledge this as a known issue that needs to be fixed.
  • @biminiroad No problem, at least it's working like this now when using the standalone Mac app. I did notice that following the symlink is not working when I want to use it to open a patch in the iCloud folder from the Audio Unit plugin.

    Hope it can get fixed soon because the idea of quickly creating something on my iPhone/iPad when some inspiration pops up while on the road and then do some more serious work on my Mac later is extremely exciting to me :)
  • Is there any update to this problem? I also sent an email about this to the support email address a few weeks ago but it was never answered.
  • @balph I'll be working on this today :)
  • Great, thanks :)
  • Hope this issue gets resolved soon.

    I'm really enjoying working on patches on my iPad but it's a bit of a drag to have to send them over to my Mac via email (like an animal). Also some strange duplication of patches stored in iCloud. Otherwise thrilled with this app.
  • I have noticed the issue with duplication of patches too, especially with the included example patches.
  • Yes, I as well would love to have a fixed version with this issue resolved. I have been using the iOS version and desktop much lately and I really want to be able to keep the files in sync
  • I've been working on this, and going back and forth with Apple's developer tech support. Hopefully we'll make some progress this week :)
  • Good to hear :)