Can't launch audulus in audiobus
  • I can't launch audulus in audiobus, neither as an effect or an instrument. Audulus shows up with the v2 icon (still owns v2 on my ipad), not the 3.0 icon. When I tap the icon, 3.0 starts but can't connect to audiobus. iOS 9.1, ipad air, last version of audiobus.
  • Same for me.
  • Please fix :(
  • Audiobus and Audulus 3 fine here.... Launches both as instrument and FX

    iOS 9.2 + latest Audiobus

    I did delete/remove earlier versions of Audulus from my iPad however..... Maybe having two different versions of Audulus on the same iPad is the problem?

    Try removing the earlier version to test after backing up iPad...


  • I'm gonna update my ios and try again.
  • I have the latest iOS and Audiobus (iPhone 5S and iPad 4). While Audiobus "launches" Audulus, playback does not appear to be through Audiobus. Audio does not make it to any FX or OUT slot. Also, Audiobus continues to show the "Zzz" and "Tap to Launch" message.

    Audulus using IAA is fine so far (only tested inside Audioshare).
  • Yes I suspect that having both versions installed is a problem, but I still need the old version to update my patches to 3.0...
  • @SansNom - no, you actually don't - you can load 2 patches into 3. If you need to, take a screenshot of all your modules in 2 before you migrate to 3, because they will look a little different. But 3 can open 2 files, they just look a little messy sometimes.
  • Well half of my patches are not v3 compatible, they just crash the app. Plus I want to check that the conversion process and the engine updates don't mess up everything, v2 is somehow my reference.
  • @SansNom, sorry to hear that - I remember at one point I loaded every old patch on the forum into 3, and it worked for me (on computer) - some patches didn't work at all, but they all loaded. Dunno what that's about! :)
  • Same problem here, Audulus does not work well/at all with latest Audiobus. I tried to tweak buffer sizes and upgraded my iOS to 9.2 but no joy. I have not had any version of Audulus installed on my iPad Air2 before. Actually, when I searched for Audulus within Audiobus app, I got a message that Audulus 3 does not support Audiobus 2.1b1. I was prompted to contact the developer with following preset mail:

    Dear Audulus LLC,
    I use and love Audulus 3, and would love to see it updated to use the 2.1b1 Audiobus SDK.
    Please consider updating - you can find the new SDK version at https://developer.audiob.us
    Many thanks.

    EDIT: Latest Audiobus SDK available is 2.3.1, so the error message is in error, too :) I deleted and re-installed Audiobus just to be sure I had the latest version (which I had). Message stays the same.

    I must say I have not been very happy with Audiobus performance lately, as there seem to be quite a lot of compability problems with many apps. Maybe Audiobus SDK updates are not very well downward compatible and perhaps app developers have not been informed of changes very actively.
  • @saminurmela, we'll have this fixed soon! I just messed up. It's easy to fix, but we still have to wait a week for Apple's approval, bleh.
  • Taylor, that's cool to hear! And thanks for replying here, my bad for not using the proper support channel.
  • you could ask for express review for such a thing
  • Any ETA on this?
  • A few days, last I heard - before Apple goes on Christmas break
  • I deleted Audulus from my iPad and now I can use IAA as an input and effect. The app launches in Audiobus but it doesn't load up within Audiobus. Hopefully Apple will approve the update fix in a few more days.

    The bad news, lost a significant amount of work in a sub patch I was working on. Just go to edit the UI and the app boots you to the desktop, when I went back in, major work on the patch was lost. Will try to recreate the patch first and then convert to sub patch after so at least I can copy it to another file as backup and won't be going up and down levels which seems to trigger the crash.
  • Any tips to avoid editing crashes other than editing on OSX would be appreciated.
  • @Paulinko You lost your work because you didn't back up your patch before you deleted Audulus, I assume, right? It's a little hard to understand what you're saying here. I'm getting confused on your nomenclature - you say "app" but then "boots you to desktop" and I'm not sure if you're still talking about iOS - there is no "desktop" in iOS, Apple calls it the "home screen." I'm just not sure if what happened here is really a bug, or if you just (unfortunately) didn't know that when you delete Audulus, it deletes everything you've created, and when you reinstall it, all you get is the defaults.

    I'll assume that you're on iOS and you're asking how to protect yourself from crashes - well, if it's working correctly, the built-in history function should let you load from where you last were before the app crashed. That said, you can, when working on larger patches, exit the patch (to the main menu, the Patch Browser) and re-enter it. I believe this may be a "safer save" than relying on the undo history alone, but @Taylor might prove that I'm wrong on this point. Either way, it should "just work" and not need some workaround like that, so thanks for bringing this to our attention.
  • By the desktop, I was referring to the home screen. The patch was all done on iOS. The history saved some of the changes but most of them were gone. This has happened to me several times and seems most prevalent editing the UI of a sub patch. I've been exiting to the patches menu and it does seem more stable that way. If I get real ambitious, I may try to see what I can do to purposefully cause crashes and report back.
  • @Paulinko - thank you, you'd be solving this for me too :) I've run into that same problem and just haven't had the time to figure out what exactly does it (but it usually isn't so catastrophic for me - it usually picks up right where I left off, or maybe 1 or 2 things are missing). We'll get to the bottom of this.
  • @biminiroad I was able to produce a corrupted knob in a sub patch by editing the UI by moving things around a lot in the module. I've circled the knob in the patch and sub patch. I was able to crash Audulus 3 by repeatedly hitting undo. When I got back into Audulus the patch was missing several layers of undo history. When I started to undo again, I was able to get the same crash and the patch was once again missing all of the things that had been fixed before doing undo (it was in the state it was in before I started doing all of the undos).
    image.png
    530 x 702 - 76K
    image.png
    1041 x 867 - 110K
  • @Paulinko - can you upload this patch so I can do the same with it? Dunno if you saw my first reply but I realized I misunderstood what you were saying.
  • @biminiroad Here's the patch. I fixed the corrupted knob but it still crashed after that.
    IAA Module Copy.audulus
    316K
  • @Paulinko - does this not work, or did it just screw up your UI? Everything seems fine to me other than the UI's in a pile.
  • @Paulinko it also seems like a lot of what you're getting out of designing this way is clarity of signal flow - you can also achieve that with text vias - here's the control signal element from your patch done a different way:

    Condensed Design.audulus
    101K
  • @Paulinko - Also, the computer version just crashes sometimes, it might not have to do with a particular thing you're doing but perhaps something with the undo or history. It all gets dumped into the crash logs that Taylor can look at, I suppose. It's hard for me to track down, but it happens. It's nice though that, for the most part, it picks up right where you left off! :)
  • Updated - Thanks, seems to work so far!