White Wires? No Sound?
  • Hey there!

    I can't for the life of me figure out why there's no sound coming out of this patch? And there's a couple of wires that turned into white!! 0_o

    There are 3 band pass filters in parallel, each cutoff is being modulated independently:

    1st one being modulated by a random signal
    2nd and 3rd ones being modulated by LFOs with different frequencies.

    Then all filters go to a mixer, and then to the output.

    Amplitude of oscillators are being modulated by an ADSR going straight into their amp slot (thanks to @Afta8, I wasn't aware of that!!)

    Pacth is attached.

    triple band pass.audulus
  • Ok call me crazy, I have just loaded the patch again and it works! How weird is that? I only know that a couple of cables turned into white color and there was no sound...
  • Updated with some delay, reverb, and added a touch of distortion on the signal modulated by the random frequency.

    Hold down E1 for at least 20 seconds for some cool sounds!!
    triple band pass tweaked.audulus
  • Another nice patch. I have so much to learn; thanks for sharing!
  • PS - I've seen the white wires in circumstances where I really bad feedback issues. It *may* be a feedback protection feature.. if a line gets too "hot," turn it off for the duration of the session. @Taylor?
  • @AlbertGauer, Nice work.
    I'll let Taylor give the accurate explanation of the dreaded white cables. Basically, it's a NaN (Not a Number) problem, like a divide-by-zero error, an undefinable number. It can propagate through a patch. Sometimes this seems to cause a node to break and the only way to fix it is to create a new node or quit the patch and restart. But occasionally, rarely, it seems as if NaN has crashed the output for the whole app and the only fix is to quit Audulus and start fresh.
  • I love that 1/0 is basically infinity. I wish they had explained us that in school - they just told us "You just can't do it so don't try" which is exactly the kind of thing that makes you say F U MATH!
  • Yeah the white cables happen when the numerical values go bad, which can corrupt all the DSP in the patch. Usually, you can just reload the patch. I've tried to avoid cases where bad values can occur (for example, if you do 1/0 in the math expression node, it just outputs 0, which is wrong, but at least won't blow up your patch). There's still more work to do.
  • Crazy stuff! Gonna try to avoid creating such cases. Easy to solve, though, just reload! Cool.

    Thanks for chiming in guys!
  • Hey I've tried a bunch of patches and a bunch of different ways of routing audio through a DAW and through Audiobus 3. I can't get any sound and I get white lanes with zero cpu usage. The very same patches work fine on my iPhone but when I go to use them on the iPad Pro 12.9inch (1st Gen) I just get white lanes no matter what I do. Any suggestions? I've spent a fair bit of time trying to find a fix including resetting all factory settings on the iPad Pro.
  • @RobbieFitzAU - can you upload (some of) the patches that don't work, and screenshots of the white wires happening? Thanks!
  • @RobbieFitzAU - are you using an OS beta also? That would be the reason. A fix for iOS11 is about to come out.