[SOLVED] Audulus on OS X crashed, now hangs when trying to re-open it
  • Audulus 2.7.1 purchased via AppStore on OS X 10.9.3. Was working perfectly, but I changed the appearance from midnight to ice, and it hung. Killed the process, tried to re-open, and now it hangs on re-opening - it offers to send a crash report - it hangs whether that offer is accepted or not. It also offers to not re-open previous windows - again, no difference, hangs either way. It gets as far as putting up the Audulus menu bar and opening a blank window titled 'Window", then it hangs in a CPU loop. Because it was installed via AppStore, I'm not sure how to re-install it. Oh, rebooting has no effect either.

    Is it safe to just delete the package from Applications and then re-install from the AppStore? I ask because I have had problems doing this with other apps in the past. (Give me a stand-alone installer over the AppStore any day...).
  • I tried deleting the entire Audulus app package from the Applications folder. The AppStore then offers to re-install it, it downloads Audulus again, re-installs it and... it still hangs in an identical fashion when trying to open it.
  • @bennelong_bicyclist, sorry about that! Try doing the following in the terminal:

    cd ~/Library/Preferences/
    rm -rf com.subatomic.antimatter.*

    Does that do the trick?
  • Nope, deleted the .plist file, same behaviour, still hangs. Does it store state anywhere else?
  • Deleting ~/Library/Containers/com.subatomic.antimatter/Data/Library/Autosave Information/com.subatomic.antimatter.plist didn't seem to help either.
  • Did you try deleting the whole container? ~/Library/Containers/com.subatomic.antimatter
  • OK, fixed. The offending file was called ~/Library/Preferences/com.subatomic.antimatter 10.54.43am.plist which the glob you suggested didn't include, but which I am sure wasn't there when I looked earlier... hmmm. Anyway, it works now, thanks.