audulus help?
  • can't modulate the frequency of the filter module. resonance input works, but frequency doesn't is this a bug? or am i doing something wrong?
  • Hey @DudeSouth, its in Hz, so you'll have to multiply by some reasonably large number to convert (0,1) to some Hz value.

    Does that work?
  • i couldn't figure that out. which module do i use to set a large number? the multi. and ?
  • btw i tried right clicking on the input of the multi. module and set default to 200, but it stays the same.
  • nevermind i think I'm getting it.. :)
  • can anyone look at this example patch and tell me what i'm doing wrong? i only added an envelope to the filter. the sound constantly cuts out when playing notes. if i take out the delay/ reverb modules it works fine.

    edit- found I needed another poly-to-mono node. I guess it's time to start reading the manual... thought I could figure things out by experimenting, but it seems there's some basics that I'm missing. i've programmed heavily in the ACE and Zebra (semi)modular synths, thought i knew synthesizers well, but Audulus has some quirks to it that aren't so obvious to me yet.
    New Patch 1.audulus
    58K
  • Hi. I tweaked a few things to help get you going. For example, I changed the top ADSR, changed the number higher on the multi in front of your filter, reversed the delay and reverb, and their settings, and added in a few levels. Hope this helps.

    -ArcaneScreams
    DudeSouth1.audulus
    58K
  • thanks for the help. weird though, I tried opening the patch and I don't see any of the changes you mentioned.
  • Try placing a poly-to-mono node after each of the audio oscillators. Audulus polyphony takes a bit of time to get your head around.
  • thx JD. removing the poly-to-mono nodes from the patch altogether helped too.
  • one thing I've noticed that I find a little strange- when I connect the envelope to the filter frequency, I can no longer adjust the frequency value in the filter window (stuck at 20 hz). when I connect to the filter resonance input however, I can still adjust the resonance value in the filter window. is that expected behavior?
  • Hey I was wrong. One Poly-to-Mono after the filter. Try it.
    Remember: Output nodes don't do poly.
    I too have observed that quirk with the resonance.
  • so basically what I need to figure out then is how to set the base frequency of the filter, before modulation occurs. for some reason the filter window only let's me drag the resonance value after I connect a modulation source so is there something else I need to do?
  • Stick a constant knob on the resonance input and start with a cutoff value in the low thousands.
  • no need for the constant knob on resonance, since I can still drag the resonance value in the filter window (it does the same thing), just can't drag the cutoff.

    if I put an envelope on the cutoff input, I still haven't found a way to set the base frequency. I should be able to set the mod amount to 0 and still get sound, but can't because the base frequency is stuck at 20hz.
  • to me it just seems I *should be able to drag the cutoff, but there's some bug that is making the cutoff get stuck. idk it just doesn't make sense to me.
  • here is the patch
    DudeSouth1-1 copy.audulus
    91K
  • Connecting to the input of the filter cutoff disables graphic input. Until the ADSR turns on, you have the cutoff set to 0. Try adding the base frequency after your multiplication.
  • thx JD, exactly right!
  • whats the best way to add the base frequency, but have the value tied to a knob with a set range (instead of having to type in the value)? i checked out the range node, but haven't figured out how to make that work yet.

    edit- Crossfade!

  • On iOS, when modulating the cutoff, I can see it moving left and right. When modulating the resonance, it doesn't move up and down like it does when I drag it. Am I missing something or is the res just not animated when it is modulated from the res input? I can hear it working, I just can't see it working.

    I've been wondering about this for years... not sure why I never asked anyone.
  • @ZenLizard, it's a bug (or an omission at least). I really should work on it :-\
  • Ah. Well... although the visual feedback would be nice, it's hardly a high priority I'm sure. I can't even imagine what a massive undertaking Audulus must be from your side of things. I can hardly keep track of what I'm doing as a user. I go off on tangents while building a patch and forget what I was trying to do in the first place. It makes for a lot of happy accidents, though.

    You could market Audulus as a relaxation app in addition to being a modular synth. I get engrossed and before I know it the stress of the day is gone. Some people pay for therapy, but I save that money for IAPs :)

    Thanks @Taylor