AU 2.2.7 fails validation on Logic 9.1.8 (32-bit mode) / OS X 10.6.8 (FIXED :-)
  • I just installed the 2.2.7 AU version, but it won't pass validation when I start Logic in 32-bit mode. Interestingly, the midi-controlled effect seems to pass validation but the instrument doesn't (see screenshot)


    Here's the output of the AU Validation Tool ...




    validating Audio Unit Audulus by Subatomic:

    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
    AU Validation Tool
    Version: 1.6.1a1
    Copyright 2003-2007, Apple, Inc. All Rights Reserved.

    Specify -h (-help) for command options
    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    --------------------------------------------------
    VALIDATING AUDIO UNIT: 'aumu' - 'anti' - 'subA'
    --------------------------------------------------
    2013-08-28 20:01:35.091 auvaltool[267:a07] *** __NSAutoreleaseNoPool(): Object 0x162184d0 of class NSCFString autoreleased with no pool in place - just leaking
    Manufacturer String: Subatomic
    AudioUnit name: Audulus
    Component Version: 2.2.0 (0x20200)

    * * PASS
    --------------------------------------------------
    TESTING OPEN TIMES:
    COLD:
    bundle path: /Library/Audio/Plug-Ins/Components/Audulus.component
    AudioEngine::SetPatch 0x1617b290
    Time to open AudioUnit: 86.089 ms
    2013-08-28 20:01:35.194 auvaltool[267:a07] *** __NSAutoreleaseNoPool(): Object 0x487f200 of class NSConcreteData autoreleased with no pool in place - just leaking
    AudioEngine::SetPatch 0x1626d690
    2013-08-28 20:01:35.208 auvaltool[267:a07] *** __NSAutoreleaseNoPool(): Object 0x4880800 of class NSConcreteData autoreleased with no pool in place - just leaking
    WARM:
    bundle path: /Library/Audio/Plug-Ins/Components/Audulus.component
    AudioEngine::SetPatch 0x161fae90
    Time to open AudioUnit: 14.145 ms
    2013-08-28 20:01:35.229 auvaltool[267:a07] *** __NSAutoreleaseNoPool(): Object 0x50a5c00 of class NSConcreteData autoreleased with no pool in place - just leaking
    AudioEngine::SetPatch 0x162746d0
    2013-08-28 20:01:35.243 auvaltool[267:a07] *** __NSAutoreleaseNoPool(): Object 0x489c800 of class NSConcreteData autoreleased with no pool in place - just leaking
    ERROR: Component Version mismatch: Res Vers = 0x20200, Comp Vers = 0x20207
    2013-08-28 20:01:35.252 auvaltool[267:a07] *** __NSAutoreleaseNoPool(): Object 0x5811c00 of class NSConcreteData autoreleased with no pool in place - just leaking
    AudioEngine::SetPatch 0x46489f0
    FIRST TIME:
    Time for initialization: 0.023 ms

    * * FAIL
    --------------------------------------------------
    AU VALIDATION FAILED: CORRECT THE ERRORS ABOVE.
    --------------------------------------------------


    validation result: failed validation
    Screen shot 2013-08-28 at 8.08.35 PM.png
    880 x 188 - 56K
  • Looks like the version is wrong for part of the instrument version:

    ERROR: Component Version mismatch: Res Vers = 0x20200, Comp Vers = 0x20207

    Sorry about that! I'll fix it and post a new version shortly.

    - Taylor
  • @Plurgid, give this version a try:

    http://content.audulus.com/Audulus Audio Unit 2.2.8.pkg

    Let me know if it works on your end :-)

    cheers
    - Taylor
  • yep works great!
    can't believe you fixed it same night!
    thanks again!
  • Sure thing! And thanks for alerting me to the problem!

    cheers
    - Taylor