Local files disappearing in iOs?
  • So I’ve been having a lot of issues of recently worked on patches not showing up in my recent files or even in the Browse section when trying to re-open them. It also seems that I’ve had some older files that I’ve worked on completely disappear or I am not able to find them on my iPad.

    When I couldn’t locate a patch I had been working on recently with browsing or searching through the iPad Audulus app, I found an older copy of the patch on my iphone and AirDropped it to the iPad. Rather than the file showing the original name “Sarlacc makeover”, it landed on the iPad as “Sarlacc makeover-1” indicating that my iPad already had a copy of this file. I still couldn’t find the original file on my iPad so I continued working on the patch as “Sarlacc makeover-1” within the iPad (changes made within patch). Fast forward a few hours and I pulled out my ipad again on a break to continue working on the patch, but I am now unable to find “Sarlacc makeover-1” or the original on my iPad or iCloud! I airdrop'd the original “Sarlacc makeover” to the iPad again and now the file drops as “Sarlacc makeover-2” as you can see in the included screenshot. Am I missing something?! For a short period of time it seemed like these patches were being updated thru the cloud no matter which device I was using and now it doesn’t update over the cloud and seems to hide my files after closing the app down. Any ideas?
    2048 x 1536 - 334K
  • 5F9369D5-213D-4BC8-8E58-D5A34F903DA9.jpeg
    2048 x 1536 - 334K
  • Have you looked at your iCloud folders using the files app or with a Mac or PC? I’ve occasionally had sync issues with iCloud with various apps. It might be useful to see what’s there without using Audulus.
  • I have a feeling that this is an apple files bug. I wish I could keep everything on dropbox, but I found that when I did that the autosaves from Audulus were generating patch-1, 2, 3 , 4, 5 etc. in the dropbox folder. I asked Taylor about it and he suggested that it was likely a bug with either dropbox or the then-new apple file system since everything within Audulus is pretty much the most standard code available.

    So yes, I have had similar things happen, but since I switched to duplicating files into the Audulus folder from inside dropbox (as opposed to from within audulus) I haven't had any issues. I'm not sure if there is something equivalent you could do but that's my story and I'm sticking to it.