Output responding but no sound on iPad 2
  • Hi sorry if this has been covered before, I have just today started using audulus on my iPad 2 and am finding the external sound disappears often although the output is still responding. Have tried using a level node to reduce output but that doesn't make a difference. I don't think I am overloading th CPU because the much larger more complex presets work fine. Is there something I am missing?
  • Hey @Klamanth, by "output is still responding" do you mean the little meter on the output node is snowing some signal? Does the problem occur with the example patches?
  • Yes the output node meter is working and not clipping (is jumping up into green etc.) But there is no sound. The problem doesn't happen with the example patches. I also noticed that the sound disappears when I switch into poly mode, not always but sometimes. Thanks.
  • If you could email me the patch, I'd be happy to take a look at it :-)

    http://audulus.com/support/
  • I noticed that happen a couple of time. I don't think it's to do with a specific patch. More likely some inadvertent multitap event. Revealing and hiding the iOS task bar restores the sound.
  • Hey @Gordon. I was able to help @Klamath via email. His patch needed a PolyToMono node at the end to mix the polyphonic signal to mono. I should make the output nodes automatically handle polyphonic connections so people don't run into that.

    If you're seeing another issue, please email me some details so I can fix it :-)

    cheers
    - Taylor
  • If I can reproduce it, I'll let you know.
  • iPad2, iU2 interface, afta8.Vocoder_16_Bands:

    no sound with meter showing signal on output node. Revealing and hiding the iOS task bar crashes Audulus. Reproducible. CPU load is around 2, I guess the iPad2 runs out of memory with this patch, or uses too much processing power.

    What is the maximum CPU load? Is 2 much or not much?

    Edit: tried it again, for the fourth time, and no crash after revealing and hiding the iOS task bar. But also no sound. Interestingly, the CPU is now clearly below 2, around 1.7.
  • A solution that has worked for me is to delete the output node and create a new one.
  • Hey @Phil999, if the cpu load is above 1, then the patch is too heavy for the iPad. I would try to keep the CPU load below .5 to ensure there isn't the occasional audio dropout.

    Its most likely crashing because the memory is exhausted. iOS doesn't have virtual memory so when an app runs over the limit, iOS just kills it.

    If you see the problem for smaller patches, please let me know, as that's a serious bug!