Bluetooth Audio issues on Ipad
  • Hi, I know this is mostly an IOS issue but I thought I'd bring it up in case anyone has any suggestions. I'm a big fan of Bluetooth headphones...but I just have very bad luck making Audulus work with Bluetooth Audio. It just stubbornly sticks to routing to speaker...and for some reason once it does forces all other Bluetooth Audio traffic to speaker as well.......One thing that's always annoyed me about IOS is that there does not seem to be anyway of redirecting audio....with the exception of airplay. Is there ANY IOS library or routine that can be utilized to redirect audio to Bluetooth?

    Sent from my iPad using Tapatalk
  • Me too. Just downloaded Audulus 3 onto my iPad.
    It is awesome! But I can't route audio out through Bluetooth, which is kind of annoying
  • Hi @plurgid, I know this isn't directly related, but I just wanted to compliment you on your phase distortion oscillator that you posted a few months ago.
  • Thanks! I've been out of the loop with Audulus the past year or so, man all this new stuff is amazeballs! I've got some catchin' up to do.
  • Most people have had success hosting Audulus in Audiobus or AUM and then pairing to Bluetooth that way - is that an option for you @doublestop?
  • Bluetooth audio not working for me on MacBook Pro. Audulus just gives an annoying buzz through the headphones when I try to use them. Any ideas?
  • @dmlh Are you sending midi or audio? edit: derp, it's audio.
  • @dmlh - can you try hosting Audulus in a DAW as a plugin and see if that forces the Bluetooth to work? Taylor just fixed this functionality for iOS but it might be a different solution for the computer.
  • Thanks for the iPad Bluetooth fix.
    Unfortunately, something's still not right :-(
    Suspect it's something to do with sample rate?
  • @plurgid thanks for the report plurgid - can you give us a little more info? does it not work at all, or only intermittently? will it work when audulus is in the background? any more info you can provide would be a big help :) Thanks!
  • I've got two different Bluetooth devices, a cheapie Bose knockoff speaker, and a fairly high end Bluetooth receiver, both behave the same way,

    The first clue is that if I've got any other audio running in the background (say pandora or Apple Music) when I launch Audulus, all the audio output immediately sounds like it's gone through a low pass filter. Even if I kill the background audio apps (and restart Audulus), still everything that comes out of Audulus to Bluetooth sounds like it's been through a low pass filter.

    Second clue is that the tap tempo module spits out WAY high values when connected to Bluetooth (which is what makes me think sample rate or something like that?)
  • @plurgid - thanks that's good info! And just to be sure: it doesn't work *at all* right? Not that it works intermittently? Also, are you on the latest iOS version? If not, which one? Thank you! We'll get this sorted soon :)

    PS: The temporary fix that was working in the past for people was to host Audulus in AUM or Audiobus - that seemed to then connect to the bluetooth fine
  • Yeah, the problem is consistent, have not witnessed it working yet.
    iOS version: 10.2.1 (14D27)
    Audulus version: 3.3.8, and App Store says it's up to date

    I've been eyeing up audiobus in the App Store, will check that out or AUM.
    Thanks again for the great support, chaps!
  • No luck here either. As suggested above It sounds like Audulus is outputting at a different sample frequency than the iPad is transmitting.It also doesnt work for me via audiobus.
  • I've also got an issue. I can't get audio through my Bose QC35's in Audulus except when it's physically plugged in. The bluetooth connection just seems to play my own microphone audio back to me but does not play any sound from Audulus at all. Other apps do work. Does anyone know what's going on here or how to fix this issue?
  • @RobbieFitzAU - have you tried the Audiobus/AUM fix suggested above? Anyway, it's on the bug list! :)
  • Hi again. So this doesn't seem to be just exclusive to Audulus. I've had similar trouble with animoog. I have only tried using the one set of headphones (Bose QC35) however I have since tried this using the headphone connection as well with no luck. Most apps seem to work fine but it seems to be the music creation apps that seem to trip it up a bit.

    I have tried as you've suggested running Audulus through Audiobus 3 into a Garageband as a DAW. It was a good suggestion. Still no luck unfortunately.

    One thing I notice is that when I open Audulus I get a hiss, as if the headphones are picking up and monitoring the sound of their own microphone. Usually noise cancelling blocks out the outside world but when I open Audulus it seems to play the microphone through the headphones. For some reason this makes Audulus silent. When I close Audulus the headphones return to ordinary noise cancelling and the bluetooth connection or cable is still strong and connected.

    I have also tried disabling the active noise cancelling with no result

    I'm running on a theory that iOS is doing something strange with the headphones. Instead of taking the sound from Audulus and playing that through my headphones it instead takes my microphone from the headphones and plays that back to me. Why? I have no idea. Perhaps because iOS knows they are noise cancelling headphones it does something funky like a signal delay which other apps don't like. If this were the case though, perhaps disabling the ANC would have fixed this which it didn't. I'm very lost here. This could be a quirk with iOS, The QC35's or music creation apps such as Audulus. I really have more questions now than before.

    Any other suggestions? I can just use my iPod headphones for now.
  • Thanks @RobbieFitzAU - this could be some good info for Taylor to track down the problem. He's been stumped by it so far, so it would explain a lot if it's something the OS is doing rather than something Audulus is doing...
  • Anyone have an update / other workarounds? FYI, I'm using the (bluetooth) Sennheiser PXC 550's, and I'm experiencing exactly the same symptoms as @RobbieFitzAU. (I have not tried Audiobus / AUM yet.)

    Additionally, the clock / timer runs at approximately 10x speed on the Mac OS X version of Audulus when using these headphones via bluetooth.
  • FYI, I installed Audiobus 3, and was able to get everything working properly.